Quebec and Canada Websites Down

Incident Report for Anytime Fitness International

Resolved

Site has been restored
Posted Oct 03, 2025 - 02:53 UTC

Investigating

We are currently investigating the issue.
Posted Oct 03, 2025 - 00:20 UTC
This incident affected: Website (Quebec).