Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 24, 2025 - 20:30 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Apr 22, 2025 - 21:27 UTC
Scheduled
We will be conducting a planned maintenance effort to the CRM servers on 4/24 at 8:30PM UTC. We anticipate that CRM may be down and inaccessible from 8:30PM -11:30PM UTC.
If you experience any issues with CRM after this work has completed, please submit a support ticket.
Posted Apr 22, 2025 - 20:23 UTC
This scheduled maintenance affected: Shared Resources (CRM - Microsoft Dynamics, CRM - Microsoft Dynamics 365).