Canada - Online Signups - Member Records Not Appearing in Club Hub

Incident Report for Anytime Fitness International

Resolved

A fix has been applied for the issue affecting completed Online Signups.

All previously impacted membership records have been corrected, and new records are now appearing normally in Club Hub and ABC.

If you experience any issues with Online Signups, please reach out through our standard support channels.
Posted Jul 21, 2026 - 15:27 UTC

Investigating

We are investigating a sporadic issue impacting some completed online signups.

In certain cases, a member may complete the online signup process, receive their agreement, and have payment processed successfully; however, the corresponding member record may not appear in Club Hub as either a prospect or member.

Our team is actively reviewing the issue to identify the cause and determine the appropriate resolution path.

We will provide another update as additional information becomes available.
Posted Jul 08, 2026 - 20:46 UTC
This incident affected: Shared Technology (Club Hub, Online Signup).