Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 07, 2026 - 23:00 UTC
Scheduled
ClubWise will remain available during the scheduled maintenance window, but users may notice a short delay in dashboard and KPI figures updating during this period.
Customer Impact
- Dashboards may refresh more slowly than usual - KPI figures may take longer to update - Core access is expected to remain available
Action Required
No action is required from customers.
Posted Jun 05, 2026 - 17:32 UTC
This scheduled maintenance affected: Software Partners (Clubwise).