Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 08, 2026 - 02:00 UTC
Scheduled
What’s Happening: -ABC Fitness will be performing scheduled maintenance to upgrade their infrastructure. During this time, all ABC Fitness services/products will be unavailable.
When: -Date: March 8th, 2026 -Time: 2:00 AM- 12:00PM UTC
Impacted Services: -All ABC Fitness Products -Online Signups -Club Hub -Any system integrating with ABC Fitness
What You Can Expect: -Brief interruptions in service (up to 30 minutes) -Affected tools may be inaccessible or slow to respond during the maintenance window -Any 3rd party applications and systems may be slow or unresponsive when attempting to access information from ABC Fitness systems -Normal service will resume once maintenance is complete
What You need to do: -No Action Needed.
Posted Feb 12, 2026 - 19:07 UTC
This scheduled maintenance affected: Billing Partners (ABC Fitness Solutions) and Shared Technology (Club Hub, Online Signup).