Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 14, 2025 - 21:00 UTC
Scheduled
ABC will have scheduled maintenance from 2:00 AM UTC to 6:00 AM UTC on 06/15/25. During this time, ABC Fitness services and products will remain available but may be subject to brief periods of latency or brief disconnects.
Customer impacts include: - Delays in all agreement processing with ABC - Club Hub iOS will error processing agreements containing a down payment - Online Signup will not allow for payment processing as services will be down
Posted Jun 12, 2025 - 17:37 UTC
This scheduled maintenance affected: Billing Partners (ABC Fitness Solutions) and Shared Technology (Club Hub, Online Signup).